At present, our extension is only certified to work correctly with Google's Chrome browser

At some point in the future we would like to be able to support additional browsers, including Firefox and Safari, however we do not have an ETA on either.

There are some browsers which have been built on the Chromium browser engine, which is an offshoot of Chrome. As such, many of these browsers are able to install Chrome extensions. PLEASE NOTE that while our extension may be able to be installed on to these browsers, we are not able to support any malfunctions which may ensue. 

We only officially support Google Chrome.

Did this answer your question?